tingting 1.0.0 icon indicating copy to clipboard operation
tingting: ^1.0.0 copied to clipboard

Automatic comparison of transcripts to originals for listening comprehension practice.

1
likes
80/ 130
pub points
0%
popularity

We analyzed this package 30 hours ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 157 API elements (5.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:tingting/ui/audioControls/audioControls.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/ui/utils/notify.dart:12:11

   ╷
12 │           FlatButton(
   │           ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/utils/notify.dart

INFO: 'FlatButton.FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/ui/utils/notify.dart:12:11

   ╷
12 │           FlatButton(
   │           ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/utils/notify.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
characters^1.0.01.2.01.2.1
equatable^1.2.31.2.62.0.3
file_picker^1.13.0+11.13.34.6.1
flutterflutter0.0.00.0.0
flutter_staggered_grid_view^0.3.20.3.40.6.1
flutter_tts^1.2.61.3.03.5.0
just_audio^0.3.20.3.40.9.27
path_provider^1.6.111.6.282.0.11
provider^4.3.14.3.36.0.3
shared_preferences^0.5.100.5.12+42.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.2
crypto-2.1.53.0.2
ffi-1.2.12.0.1
file-6.1.26.1.2
file_picker_platform_interface-1.3.12.0.0
flutter_plugin_android_lifecycle-1.0.112.0.6
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
rxdart-0.24.10.27.4
shared_preferences_linux-0.0.2+42.1.1
shared_preferences_macos-0.0.1+112.0.4
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.1
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
uuid-2.2.23.0.6
vector_math-2.1.22.1.2
win32-2.6.12.7.0
xdg_directories-0.1.20.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.2.3` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^1.13.0+1` on file_picker does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

1
likes
80
pub points
0%
popularity

Publisher

unverified uploader

Automatic comparison of transcripts to originals for listening comprehension practice.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

characters, equatable, file_picker, flutter, flutter_staggered_grid_view, flutter_tts, just_audio, path_provider, provider, shared_preferences

More

Packages that depend on tingting