timber_firebase_analytics 0.1.0
timber_firebase_analytics: ^0.1.0 copied to clipboard

Timber Tree implementation for Firebase Analytics.

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 19 API elements (15.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:timber_firebase_analytics/timber_firebase_analytics.dart that imports:
  • package:firebase_analytics/firebase_analytics.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_analytics^7.0.07.1.18.3.3
flutterflutter0.0.00.0.0
pedantic>=1.0.0 <2.0.01.11.11.11.1
quiver>=2.0.0 <3.0.02.1.53.0.1+1
timber^0.3.20.3.21.0.0+1
time_machine>=0.9.0 <1.0.00.9.160.9.16
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
firebase-9.0.29.0.2
firebase_analytics_platform_interface-1.1.02.0.1
firebase_analytics_web-0.2.0+10.3.0+1
firebase_core-1.7.01.7.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
logging-0.11.41.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^7.0.0` on firebase_analytics does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions firebase_analytics to update the constraint.

The constraint `>=2.0.0 <3.0.0` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.