tiler 0.1.4

Tiler #

A Dart/Flutter library for rendering maps created with the Tiled map editor in Dart/Flutter.

Example map in the Tiled editor:

Example map rendered in Flutter using Tiler:

0.1.4 #

  • Fix incorrect rendering of tiles that are both rotated and flipped.

0.1.3 #

  • Fix bad door tiles in example project map.
  • Fix many path-related issues when loading images in external tilesets.
  • Add basic automated tests with golden images.
  • Improve the names of some generated enums.

0.1.2 #

  • Include generated code so that package, er, works.

0.1.1 #

  • Lower the minimum SDK from 2.2.1 to 2.2.1-dev.2.0 to include Flutter stable SDK.

0.1.0 #

  • Initial release with basic rendering of JSON maps from Tiled.

example/README.md

Tiler - Example App #

Example app for the Tiler library. The repo does not contain all of the android/ios/etc. folders so run flutter create . in this folder to re-create them before trying to run.

Example map in the Tiled editor:

Example map rendered in Flutter using Tiler:

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tiler: ^0.1.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tiler/tiler.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.1-dev.2.0 <3.0.0
flutter 0.0.0
json_annotation ^2.2.0 2.4.0 3.0.0
meta ^1.1.6 1.1.7
path ^1.6.2 1.6.4
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner any
flutter_test
json_serializable any