tiger_dialogbox 0.0.1

Flutter Android iOS web

Animated Customizable Dialog Box.

1
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 20 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dialog_box.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/tiger_dialogbox.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flare_flutter^1.5.81.8.32.0.6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
flare_dart-2.3.42.3.4
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.5.8` on flare_flutter does not support the latest published version `2.0.6`

pubspec.yaml:13:18

   ╷
13 │   flare_flutter: ^1.5.8
   │                  ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs