test_core 0.3.28
test_core: ^0.3.28 copied to clipboard

A basic library for writing tests and running them on the VM.

0
likes
120 / 130
pub points
98 %
popularity

We analyzed this package on Jun 16, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 80 out of 87 API elements (92.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.0.01.7.01.7.1
args^2.0.02.1.12.1.1
async^2.5.02.7.02.7.0
boolean_selector^2.1.02.1.02.1.0
collection^1.15.01.15.01.15.0
coverage^1.0.01.0.31.0.3
frontend_server_client^2.1.02.1.02.1.0
glob^2.0.02.0.12.0.1
io^1.0.01.0.01.0.0
matcherany0.12.100.12.10
meta^1.3.01.4.01.4.0
package_config^2.0.02.0.02.0.0
path^1.8.01.8.01.8.0
pedantic^1.10.01.11.01.11.0
pool^1.5.01.5.01.5.0
source_map_stack_trace^2.1.02.1.02.1.0
source_maps^0.10.100.10.100.10.10
source_span^1.8.01.8.11.8.1
stack_trace^1.10.01.10.01.10.0
stream_channel^2.1.02.1.02.1.0
test_api0.4.10.4.10.4.1
vm_service>=6.0.0 <8.0.07.1.07.1.0
yaml^3.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.022.0.0
charcode-1.3.11.3.1
cli_util-0.3.00.3.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-6.1.26.1.2
logging-1.0.11.0.1
pub_semver-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.17.1, Dart 2.13.1.