test_api 0.3.0
test_api: ^0.3.0 copied to clipboard

A library for writing Dart tests.

1
likes
90 / 130
pub points
98 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 151 out of 169 API elements (89.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: 'formatFailure' is deprecated and shouldn't be used. Will be removed in 0.13.0..

lib/src/frontend/async_matcher.dart:41:16

   ╷
41 │           fail(formatFailure(this, item, realResult as String));
   │                ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/frontend/async_matcher.dart

INFO: 'ErrorFormatter' is deprecated and shouldn't be used. Will be removed in 0.13.0..

lib/src/frontend/expect.dart:56:47

   ╷
56 │     @Deprecated('Will be removed in 0.13.0.') ErrorFormatter? formatter}) {
   │                                               ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/frontend/expect.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because test_api depends on test_core from path which doesn't exist (could not find package test_core at "../test_core"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.