tencent_ad 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 51

tencent_ad #

Flutter腾讯广告插件, 目前只支持Android,IOS端正在封装

1.0.0 #

  • 更新内容 ● 集成Android端腾讯广告,包含横幅、插屏、渲染模版、闪屏等广告页面。 ● Android端使用的Jar包为X5增强版,4.11 https://adnet.qq.com/resource/sdk ● Android端的插屏弹窗广告目前显示异常,待解决。 ● Android端运行Demo项目,自动生成的绑定插件类是Java文件,而源码是Kotlin, 调用静态方法需要手动修改为 Companion 。 ● IOS端仅能运行静态页面,尚未调用到库。

example/README.md

tencent_ad_example #

Demonstrates how to use the tencent_ad plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tencent_ad: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tencent_ad/tencent_ad.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/inters.dart.

Run flutter format to format lib/inters.dart.

Format lib/native.dart.

Run flutter format to format lib/native.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test