telereso_generator 0.0.10-alpha
telereso_generator: ^0.0.10-alpha copied to clipboard

Telereso implemntation to generate wrapper for your Intl implemntation .

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

SDK issues found:

Package is not compatible with the Dart SDK.

Because:

  • telereso_generator that depends on:
  • telereso that is a package requiring null.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/remote_generator.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/telereso_generator.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.41.20.41.22.7.0
build^1.6.11.6.22.1.1
source_gen^0.9.10+10.9.10+31.1.1
telereso^0.0.10-alpha0.0.10-alpha0.0.10-alpha
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.030.0.0
archive-3.1.63.1.6
args-2.3.02.3.0
async-2.8.22.8.2
cached_network_image-2.5.13.1.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-1.3.122.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_core-0.5.31.8.0
firebase_core_platform_interface-2.1.04.0.1
firebase_core_web-0.2.1+11.1.0
firebase_messaging-7.0.310.0.9
firebase_remote_config-0.4.30.11.0+2
flutter-0.0.00.0.0
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.1.2
flutter_web_plugins-0.0.00.0.0
glob-2.0.22.0.2
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-3.0.83.0.8
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
octo_image-0.3.01.0.0+1
package_config-1.9.32.0.2
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
pub_semver-2.1.02.1.0
quiver-2.1.53.0.1+1
rxdart-0.25.00.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sprintf-4.1.06.0.0
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.41.2` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.6.1` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
50
pub points
0%
popularity

Publisher

telereso.io

Telereso implemntation to generate wrapper for your Intl implemntation .

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, source_gen, telereso

More

Packages that depend on telereso_generator