telereso 0.0.10-alpha
telereso: ^0.0.10-alpha copied to clipboard

Control your application's resources (strings ,images) remotely using firebase and out of the box by extending your current implementation.

1
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 46 API elements (47.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:telereso/telereso.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/telereso.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.5.02.5.13.1.0
firebase_messaging^7.0.37.0.310.0.9
firebase_remote_config^0.4.30.4.30.11.0+2
flutterflutter0.0.00.0.0
sprintf^4.0.24.1.06.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_core-0.5.31.8.0
firebase_core_platform_interface-2.1.04.0.1
firebase_core_web-0.2.1+11.1.0
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-3.0.83.0.8
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
octo_image-0.3.01.0.0+1
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
quiver-2.1.53.0.1+1
rxdart-0.25.00.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.5.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^7.0.3` on firebase_messaging does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
80
pub points
0%
popularity

Publisher

telereso.io

Control your application's resources (strings ,images) remotely using firebase and out of the box by extending your current implementation.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

cached_network_image, firebase_messaging, firebase_remote_config, flutter, sprintf

More

Packages that depend on telereso