td_json_client 0.0.2 copy "td_json_client: ^0.0.2" to clipboard
td_json_client: ^0.0.2 copied to clipboard

Dart TDLib JSON client

0
likes
135/ 160
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 135 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/Taraxa-project/echo/tree/main/packages/td_json_client was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/Taraxa-project/echo/tree/main/packages/td_json_client was unreachable. Make sure that the website is reachable via HEAD requests.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:8:53

  ╷
8 │ <code>dhttpd --path doc/api</code> and access it at <a href="http://localhost:8080">localhost:8080</a>.</p>
  │                                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSL-1.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 44 API elements (56.8 %) have documentation comments.

Some symbols that are missing documentation: td_api, td_api.BoolMap, td_api.BoolMap.toMap, td_api.DoubleMap, td_api.DoubleMap.toMap.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:td_json_client/td_json_client.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:td_json_client/td_json_client.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:td_json_client/td_json_client.dart that declares support for platforms: Windows, Linux, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6518 issues. Showing the first 2:

INFO: The variable name 'init_dart_api_dl' isn't a lowerCamelCase identifier.

lib/src/lib_td_json_log_callback.dart:21:7

   ╷
21 │   int init_dart_api_dl(
   │       ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/lib_td_json_log_callback.dart

INFO: The variable name '_init_dart_api_dlPtr' isn't a lowerCamelCase identifier.

lib/src/lib_td_json_log_callback.dart:29:14

   ╷
29 │   late final _init_dart_api_dlPtr =
   │              ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/lib_td_json_log_callback.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.0 2.1.2 2.1.2
logging ^1.0.2 1.2.0 1.2.0
path ^1.8.0 1.9.0 1.9.0
quiver ^3.1.0 3.2.1 3.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.19.0 1.19.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.