system_tasks_dart 0.2.0

Dart native
Flutter Android iOS

Get a list of system processes, and you can kill, start, restart a process

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/system_tasks_dart_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:system_tasks_dart/system_tasks_dart.dart that imports:
  • package:system_tasks_dart/src/system_tasks_dart_base.dart that imports:
  • package:process_run/process_run.dart that imports:
  • package:process_run/src/dev_process_run.dart that imports:
  • package:process_run/cmd_run.dart that imports:
  • package:process_run/src/flutterbin_cmd.dart that imports:
  • package:process_run/src/process_cmd.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: Use rethrow to rethrow a caught exception.

lib/src/system_tasks_dart_base.dart:36:7

   ╷
36 │       throw e;
   │       ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/system_tasks_dart_base.dart

INFO: Prefer using /// for doc comments.

lib/src/system_tasks_dart_base.dart:50:3

   ╷
50 │ ┌   /**
51 │ │    * 杀死此进程
52 │ └    */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/system_tasks_dart_base.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
process_run^0.10.70.10.12+30.11.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
io-0.3.40.3.4
meta-1.2.31.2.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.7` on process_run does not support the latest published version `0.11.0+2`

pubspec.yaml:10:16

   ╷
10 │   process_run: ^0.10.7
   │                ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

Get a list of system processes, and you can kill, start, restart a process

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ajanuw1995@gmail.com

License

MIT (LICENSE)

Dependencies

process_run

More

Packages that depend on system_tasks_dart