swagger_parser 1.16.2 copy "swagger_parser: ^1.16.2" to clipboard
swagger_parser: ^1.16.2 copied to clipboard

Package that generates REST clients and data classes from OpenApi definition file

45
likes
140/ 140
pub points
75%
popularity

We analyzed this package 45 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://omega-r.com was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

208 out of 208 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:swagger_parser/swagger_parser.dart that imports:
  • package:swagger_parser/src/generator/generator/generator_processor.dart that imports:
  • package:swagger_parser/src/generator/generator/generator.dart that imports:
  • package:swagger_parser/src/utils/file/io_file.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.2 2.4.2 2.4.2
collection ^1.18.0 1.18.0 1.18.0
meta ^1.11.0 1.12.0 1.12.0
path ^1.9.0 1.9.0 1.9.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

45
likes
140
pub points
75%
popularity

Publisher

verified publishercarapacik.dev

Package that generates REST clients and data classes from OpenApi definition file

Homepage
Repository (GitHub)
View/report issues

Topics

#swagger #openapi #codegen #api #rest

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, collection, meta, path, yaml

More

Packages that depend on swagger_parser