super_strapi 0.9.0-alpha+3
super_strapi: ^0.9.0-alpha+3 copied to clipboard

A Strapi dev library for Dart developers for dart class generation from strapi models and doing graph queries.

3
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.3.02.3.0
code_builder^3.7.03.7.04.1.0
dart_styleany2.2.02.2.0
inflection2^0.4.30.4.30.4.3
path^1.7.01.8.01.8.0
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
analyzer-2.8.02.8.0
async-2.8.22.8.2
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
fixnum-1.0.01.0.0
glob-2.0.22.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
package_config-2.0.22.0.2
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.7.0` on code_builder does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions code_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • super_strapi that depends on:
  • inflection2 that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Dart 2.14.4.

3
likes
80
pub points
0%
popularity

Publisher

yadunandan.xyz

A Strapi dev library for Dart developers for dart class generation from strapi models and doing graph queries.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, code_builder, dart_style, inflection2, path, yaml

More

Packages that depend on super_strapi