studentvueclient 0.0.7 copy "studentvueclient: ^0.0.7" to clipboard
studentvueclient: ^0.0.7 copied to clipboard

a client library for the student vue grade system

0
likes
25/ 140
pub points
1%
popularity

We analyzed this package 4 days ago, and awarded it 25 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.10.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.10.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.10.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
25
pub points
1%
popularity

Publisher

unverified uploader

a client library for the student vue grade system

Repository (GitHub)
View/report issues

License

Apache-2.0 (LICENSE)

Dependencies

dio, html_unescape, xml

More

Packages that depend on studentvueclient