stream_state 0.1.4

Flutter Android iOS web

A very simple and easy to use state management option for those new to declarative / react style programming. It has no boilerplate and supports automatic state persistence.

3
likes
110 / 110
pub points
60 %
popularity

We analyzed this package on Oct 15, 2020, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 35 API elements (71.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:stream_state/stream_state.dart that imports:
  • package:stream_state/src/stream_state_persist.dart that imports:
  • package:stream_state/src/init_hive_adapters/init_hive_mobile.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:stream_state/stream_state.dart that imports:
  • package:stream_state/src/stream_state_persist.dart that imports:
  • package:stream_state/src/init_hive_adapters/init_hive_mobile.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Windows

Because:

  • package:stream_state/stream_state.dart that imports:
  • package:stream_state/src/stream_state_persist.dart that imports:
  • package:stream_state/src/init_hive_adapters/init_hive_mobile.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform Linux

Because:

  • package:stream_state/stream_state.dart that imports:
  • package:stream_state/src/stream_state_persist.dart that imports:
  • package:stream_state/src/init_hive_adapters/init_hive_mobile.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:stream_state/stream_state.dart that imports:
  • package:stream_state/src/stream_state_persist.dart that imports:
  • package:stream_state/src/init_hive_adapters/init_hive_mobile.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
hive^1.4.31.4.4+11.4.4+1
hive_flutter^0.3.10.3.10.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
intl-0.16.10.16.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
path-1.7.01.8.0-nullsafety.1
path_provider-1.6.211.6.21
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
110
pub points
60%
popularity

A very simple and easy to use state management option for those new to declarative / react style programming. It has no boilerplate and supports automatic state persistence.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

zacharydimaria@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, hive, hive_flutter

More

Packages that depend on stream_state