store_version_checker 1.0.1 copy "store_version_checker: ^1.0.1" to clipboard
store_version_checker: ^1.0.1 copied to clipboard

A lightweight flutter plugin to check if your app is up-to-date on Google Play Store or Apple App Store

store_version_checker #

Installing #

Add App Version Checker to your pubspec:

dependencies:
  store_version_checker: any # or the latest version on Pub

Usage #

  final _checker = StoreVersionChecker();

  @override
  void initState() {
    super.initState();
    checkVersion();
  }
  
  void checkVersion() async {
    _checker.checkUpdate().then((value) {
      print(value.canUpdate); //return true if update is available
      print(value.currentVersion); //return current app version
      print(value.newVersion); //return the new app version
      print(value.appURL); //return the app url
      print(value.errorMessage); //return error message if found else it will return null
    });
  }
5
likes
120
pub points
81%
popularity

Publisher

unverified uploader

A lightweight flutter plugin to check if your app is up-to-date on Google Play Store or Apple App Store

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, http, package_info_plus

More

Packages that depend on store_version_checker