stomp 0.8.0

Dart native js
Flutter Android iOS web

Dart STOMP client for easy messaging interoperability.

3
likes
70 / 110
pub points
78 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Documentation URL is insecure.

Update the documentation field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 6 links are insecure.

README.md:2:4

  ╷
2 │ <p><a href="http://stomp.github.io/">STOMP</a> Dart client for communicating with STOMP complaint messaging brokers and servers.</p>
  │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 84 out of 123 API elements (68.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 157 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/impl/plugin.dart:11:1

   ╷
11 │ ┌ /** The error callback.
12 │ │  *
13 │ │  * * [error] - the error. It could be an exception, or
14 │ │  * an event (e.g., received in `WebSocket.onError`)
15 │ └  */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/impl/plugin.dart

INFO: Prefer using /// for doc comments.

lib/impl/plugin.dart:19:1

   ╷
19 │ ┌ /** A STOMP connector for binding with different networking, such as
20 │ │  * WebSocket and Socket.
21 │ └  */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/impl/plugin.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
quiverany2.1.4+12.1.4+1
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.90.12.9
meta-1.2.31.2.3
path-1.7.01.7.0
stack_trace-1.9.51.9.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
78%
popularity

Dart STOMP client for easy messaging interoperability.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

tomyeh@rikulo.org

License

Apache 2.0 (LICENSE)

Dependencies

quiver

More

Packages that depend on stomp