sticker_framework 0.0.1

Flutter Android iOS web

a sticker framework

1
likes
75 / 110
pub points
37 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://juejin.im/user/5a74437bf265da4e896aa1ed was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 108 out of 290 API elements (37.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

lib/element_container_widget.dart:30:58

   ╷
30 │   Set<ElementActionListener> mElementActionListenerSet = {}; // 监听列表
   │                                                          ^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/element_container_widget.dart

INFO: Prefer using /// for doc comments.

lib/rule_line_element_container_widget.dart:157:3

    ╷
157 │ ┌   /**
158 │ │    * 检查当前元素是否处于哪条规则中view 中心的时候可以进行提醒
159 │ │    *
160 │ │    * @return 返回当前元素处于哪条规则中
161 │ └    */
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/rule_line_element_container_widget.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
75
pub points
37%
popularity

a sticker framework

Homepage

Documentation

API reference

Uploader

a1018998632@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on sticker_framework