stemmer 1.1.0

Dart native js
Flutter Android iOS web

A NLTK-port to perform stemming in Dart / Flutter and reduce words to its base.

stemmer #

This package implements a stemming algorithm in Dart. Currently, it only supports PorterStemmer. It is a port of the exceptional Python NLTK library.

About #

This package allows for stemming of words. This process reduces a word to their base form. In many cases, the word will not even be recognisable. Where, for example, running would be stemmed to run, which is still a valid word, yet agreed would be stemmed to agre.

Example #

import 'package:stemmer/stemmer.dart';

PorterStemmer stemmer = PorterStemmer();
stemmer.stem('running');
// run
0
likes
110
pub points
56%
popularity

A NLTK-port to perform stemming in Dart / Flutter and reduce words to its base.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

japborst@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

test

More

Packages that depend on stemmer