steel_crypt 3.0.0+1 copy "steel_crypt: ^3.0.0+1" to clipboard
steel_crypt: ^3.0.0+1 copied to clipboard

A comprehensive library of high-level, cryptographic APIs. This library supports hashing, password hashing, two-way encryption, MAC authentication, and key/IV generation.

70
likes
140/ 160
pub points
93%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/AKushWarrior/steel_crypt/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

60 out of 93 API elements (64.5 %) have documentation comments.

Some symbols that are missing documentation: steel_crypt.AesCrypt.cbc, steel_crypt.AesCrypt.cfb64, steel_crypt.AesCrypt.ctr, steel_crypt.AesCrypt.ecb, steel_crypt.AesCrypt.gcm.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 47 issues. Showing the first 2:

WARNING: The value of the field '_hmac' isn't used.

lib/src/encoded/pass.dart:17:9

   ╷
17 │   HMac? _hmac;
   │         ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/encoded/pass.dart

INFO: The file name 'Poly1305.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/MACs/Poly1305.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
pointycastle ^3.0.1 3.9.1 3.9.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
js - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

70
likes
140
pub points
93%
popularity

Publisher

verified publisherkishoredev.live

A comprehensive library of high-level, cryptographic APIs. This library supports hashing, password hashing, two-way encryption, MAC authentication, and key/IV generation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (license)

Dependencies

args, pointycastle

More

Packages that depend on steel_crypt