starfruit 2.0.0 copy "starfruit: ^2.0.0" to clipboard
starfruit: ^2.0.0 copied to clipboard

A mathematical library extending and bettering provided dart and dart:math functions.

9
likes
150/ 160
pub points
54%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 24 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The variable name 'Sx' isn't a lowerCamelCase identifier.

lib/src/math/stats/pairedstatsutils.dart:25:9

   ╷
25 │     var Sx = x.stdDev;
   │         ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/math/stats/pairedstatsutils.dart

INFO: The variable name 'Sy' isn't a lowerCamelCase identifier.

lib/src/math/stats/pairedstatsutils.dart:26:9

   ╷
26 │     var Sy = y.stdDev;
   │         ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/math/stats/pairedstatsutils.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
linalg ^0.4.0 0.4.0 0.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

9
likes
150
pub points
54%
popularity

Publisher

verified publisherkishoredev.live

A mathematical library extending and bettering provided dart and dart:math functions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (license)

Dependencies

linalg

More

Packages that depend on starfruit