standard_library 0.0.0

  • Readme
  • Changelog
  • Installing
  • 48

Dart Standard Library #

Pub Version Lint & Test

Introduction #

This library provides various data structures and algorithms. The purpose of the library is to make Dart more advanced-programmer-friendly language, and not just mainly a tool for Flutter applications.

The library is under active development. Current version is 0.0.0 because it has no functionality yet.

Installation #

This is a production-level dependency, therefore install it simply by putting it under your dependencies in pubspec.yml file.

  standard_library: ^0.0.0

Changelog #

0.0.0 #

  • Initialize package on pub

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  standard_library: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:standard_library/standard_library.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0
test_coverage ^0.4.1