stack_overlay 0.1.1 copy "stack_overlay: ^0.1.1" to clipboard
stack_overlay: ^0.1.1 copied to clipboard

A Widget that displays 2 overlayed widgets and an optional wallpaper, the foreground Widget can be shown and hidden.

2
likes
35/ 140
pub points
0%
popularity

We analyzed this package 44 hours ago, and awarded it 35 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:12:1

   ╷
12 │ <img src="http://butterfly-mobile.uk/wp-content/uploads/2018/11/stackoverlay.gif" />
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.0.0-dev.28.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0. Cannot run `flutter pub outdated`.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.0.0-dev.28.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.0.0-dev.28.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.0)

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.0.0-dev.28.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

2
likes
35
pub points
0%
popularity

Publisher

verified publisherspiralarm.uk

A Widget that displays 2 overlayed widgets and an optional wallpaper, the foreground Widget can be shown and hidden.

Repository (GitHub)
View/report issues

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on stack_overlay