sprinkle 0.0.5

Flutter Android iOS web

A convenient, stream-based Flutter architecture

14
likes
60 / 110
pub points
76 %
popularity

We analyzed this package on Sep 18, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 69 API elements (4.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/SprinkleExtension.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/sprinkle.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.23.10.23.10.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:12:11

   ╷
12 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

14
likes
60
pub points
76%
popularity

A convenient, stream-based Flutter architecture

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ozaiste@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on sprinkle