split 0.0.7

Dart js
Flutter web

Minimal package containing 'split' third_party dependency used by package:devtools.

1
likes
70 / 110
pub points
67 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/flutter/devtools/tree/master/third_party/packages/split was unreachable.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:45:39

   ╷
45 │ <p>Include with a module bundler like <a href="http://rollupjs.org/">rollup</a> or <a href="https://webpack.github.io/">webpack</a>:</p>
   │                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Links in `README.md` should be secure. 5 image links are insecure.

README.md:356:6

    ╷
356 │ <p>| <img src="http://i.imgur.com/dJC1GUv.png" width="48px" height="48px" alt="Chrome logo"> | <img src="http://i.imgur.com/o1m5RcQ.png" width="48px" height="48px" alt="Firefox logo"> | <img src="http://i.imgur.com/8h3iz5H.png" width="48px" height="48px" alt="Internet Explorer logo"> | <img src="http://i.imgur.com/iQV4nmJ.png" width="48px" height="48px" alt="Opera logo"> | <img src="http://i.imgur.com/j3tgNKJ.png" width="48px" height="48px" alt="Safari logo"> | <a href="https://saucelabs.com"><img src="https://i.imgur.com/29eVTCg.png" height="28px" alt="Sauce Labs"></a> |
    │      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 11 API elements (45.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:split/split.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.1+10.6.20.6.2
meta^1.1.01.2.31.2.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs