speech_recognition 0.3.0+1 icon indicating copy to clipboard operation
speech_recognition: ^0.3.0+1 copied to clipboard

A flutter plugin to use the speech recognition on iOS and Android

51
likes
95/ 130
pub points
87%
popularity

We analyzed this package 4 days ago, and awarded it 95 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:98:1

   ╷
98 │ <a href="http://flutter.io/">documentation</a>.</p>
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 24 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:speech_recognition/speech_recognition.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:speech_recognition/speech_recognition.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:speech_recognition/speech_recognition.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:speech_recognition/speech_recognition.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

51
likes
95
pub points
87%
popularity

Publisher

shield icon for verified publishersrxlabz.com

A flutter plugin to use the speech recognition on iOS and Android

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on speech_recognition