speakeasy 0.0.2

  • README.md
  • Installing
  • Versions
  • 0


A private pub server for Dart

Build Status

Installing #


Use cases #

  1. Use private packages.

    Allows you to use the pub package system in your company without exposing code to the public, and use your private packages just as easily as public ones.

  2. Cache pub.dartlang.org.

    Reduces latency to users. Packages are cached from pub.dartlang.org and are available as long as the server is running ensuring reliability for CI systems.

Inspiration #

Speakeasy was inspired by Sinopia a private npm server and contains a similar configuration process.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  speakeasy: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:speakeasy/configuration.dart';
import 'package:speakeasy/repository.dart';
Version Uploaded Documentation Archive
0.0.2 Feb 28, 2017 Go to the documentation of speakeasy 0.0.2 Download speakeasy 0.0.2 archive
0.0.1 Feb 28, 2017 Go to the documentation of speakeasy 0.0.1 Download speakeasy 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0