spea_mobile_socket_conn 1.0.21

Package to easly connect to spea equipment.

0
likes
30 / 110
pub points
0 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://spea.com was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 12 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:spea_mobile_socket_conn/spea_mobile_socket_conn.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: A value of type 'WifiConnectionStatus' can't be assigned to a variable of type 'String'.

lib/spea_mobile_socket_conn.dart:387:23

    ╷
387 │     connectionState = await WifiConfiguration.connectToWifi(ssid, pwd, widget.appId);
    │                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/spea_mobile_socket_conn.dart

INFO: The value of the local variable 'map' isn't used.

lib/spea_mobile_socket_conn.dart:34:25

   ╷
34 │     Map<String,dynamic> map = new Map();
   │                         ^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/spea_mobile_socket_conn.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.3+50.4.9+52.0.0
flutterflutter0.0.00.0.0
fluttertoast^3.1.33.1.37.1.1
shared_preferences^0.5.3+10.5.12+20.5.12+2
spea_mobile_qrcode^0.0.30.0.30.0.3
wifi^0.1.50.1.50.1.5
wifi_configuration^1.0.31.2.11.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
connectivity_for_web-0.3.1+20.3.1+2
connectivity_macos-0.1.0+50.1.0+5
connectivity_platform_interface-1.0.61.0.6
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.16.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
path-1.7.01.8.0-nullsafety.2
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
qr_code_scanner-0.0.130.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.3+5` on connectivity does not support the latest published version `2.0.0`

pubspec.yaml:17:17

   ╷
17 │   connectivity: ^0.4.3+5
   │                 ^^^^^^^^
   ╵
The constraint `^3.1.3` on fluttertoast does not support the latest published version `7.1.1`

pubspec.yaml:19:17

   ╷
19 │   fluttertoast: ^3.1.3
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs