smartdata_generator 0.0.1 icon indicating copy to clipboard operation
smartdata_generator: ^0.0.1 copied to clipboard

SmartData Generator to automatically generate random testdata generators

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add smartdata_generator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  smartdata_generator: ^0.0.1

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:smartdata_generator/code_builders/generator_class_builder.dart';
import 'package:smartdata_generator/code_builders/init_builder.dart';
import 'package:smartdata_generator/code_builders/library_builder.dart';
import 'package:smartdata_generator/generators/smartdata_generator.dart';
import 'package:smartdata_generator/integrations/build.dart';
0
likes
110
pub points
5%
popularity

Publisher

unverified uploader

SmartData Generator to automatically generate random testdata generators

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, code_builder, path, smartdata, source_gen

More

Packages that depend on smartdata_generator