smart_select 3.0.3

Flutter Android iOS web

Smart select allows you to easily convert your usual form selects into dynamic pages with various choices input.

57
likes
100 / 110
pub points
90 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 139 out of 150 API elements (92.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

INFO: 'headline' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline5. This feature was deprecated after v1.13.8..

lib/src/choices_empty.dart:17:20

   ╷
17 │                   .headline
   │                    ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/choices_empty.dart

INFO: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

lib/src/choices_empty.dart:25:20

   ╷
25 │                   .subhead
   │                    ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/choices_empty.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider>=4.0.0 <5.0.04.3.2+24.3.2+2
sticky_headers>=0.1.8+1 <1.0.00.1.8+10.1.8+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
nested-0.0.40.0.4
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

57
likes
100
pub points
90%
popularity

Smart select allows you to easily convert your usual form selects into dynamic pages with various choices input.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

davigmacode@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, provider, sticky_headers

More

Packages that depend on smart_select