slider_with_interval 0.0.1 icon indicating copy to clipboard operation
slider_with_interval: ^0.0.1 copied to clipboard

A new Flutter package project.

1
likes
105/ 140
pub points
52%
popularity

We analyzed this package 4 days ago, and awarded it 105 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 32 API elements (65.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/slider_with_interval.dart:811:26

    ╷
811 │       Overlay.of(context)!.insert(overlayEntry!);
    │                          ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/slider_with_interval.dart

INFO: Import of a library in the 'lib/src' directory of another package.

lib/slider_with_interval.dart:16:8

   ╷
16 │ import 'package:flutter/src/material/constants.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/slider_with_interval.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

1
likes
105
pub points
52%
popularity

Publisher

unverified uploader

A new Flutter package project.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on slider_with_interval