skyscrapeapi 1.3.1+1
skyscrapeapi: ^1.3.1+1 copied to clipboard

outdated

SkyMobile API is the API that was taken from the original SkyMobile app. SkyMobile API allows easy Skyward access for developers.

SkyScrapeAPI #

SkyMobile API is the API that was taken from the original SkyMobile app.

SkyMobile API allows easy Skyward access for developers.

Quick Start Guide #

To start, you must have already included skyscrapeapi in your pubspec.yaml file.

Next, you must import the following.

    import 'package:skyscrapeapi/skywardAPICore.dart';
    //Optional
    import 'package:skyscrapeapi/skywardAPITypes.dart';

Importing SkywardAPITypes is optional, though it helps immensely with managing types and avoiding errors with your code.

Some of the most important methods you need to know are listed below.

  • getSkywardAuthenticationCodes
  • getGradeBookTerms
  • getGradeBookGrades
  • getAssignmentsFromGradeBox
  • getAssignmentInfoFromAssignment
  • getHistory

These are essential functions that will navigate through Skyward and return SkyScrapeAPI types.

An example of all this code would be located here.

More information can be provided by the documentation generated by flutter.

If you find a bug or have any questions, please contact me at my email: hunter.han@gmail.com

2
likes
0
pub points
0%
popularity

Publisher

clearhall.dev

SkyMobile API is the API that was taken from the original SkyMobile app. SkyMobile API allows easy Skyward access for developers.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

flutter, html, http

More

Packages that depend on skyscrapeapi