sky_background 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 68

sky_background #

License: MIT Pub

The sky is beautiful! Now you can transfer a piece of the sky to your application using this library 👍

How to use #

Just wrap your widget in SkyBackground

import 'package:sky_background/sky_background.dart';

  Widget build(BuildContext context) {
    return Scaffold(
      body: SkyBackground(
        child: Center(
          child: Text('Widget'),

Demo #

Issues #

If you encounter problems, open an issue. Pull request are also welcome.

0.1.2 #

  • Correct

0.1.1 #

  • Change description of package

0.1.0 #

  • Initial version


import 'package:flutter/material.dart';
import 'package:sky_background/sky_background.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return MaterialApp(
      home: MyHomePage(),

class MyHomePage extends StatefulWidget {
  _MyHomePageState createState() => _MyHomePageState();

class _MyHomePageState extends State<MyHomePage> {
  Widget build(BuildContext context) {
    return Scaffold(
        body: SkyBackground(
      child: Center(
        child: Text(
          style: TextStyle(fontSize: 24, fontWeight: FontWeight.bold),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  sky_background: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:sky_background/sky_background.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [sky_background] that is in a package requiring null.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies