single_searchable_dropdown 1.0.1 icon indicating copy to clipboard operation
single_searchable_dropdown: ^1.0.1 copied to clipboard

Single Searchable Dropdown

0
likes
60/ 140
pub points
22%
popularity

We analyzed this package 3 days ago, and awarded it 60 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 30 API elements (40.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: The method 'FlatButton' isn't defined for the type '_DropdownDialogState'.

lib/single_searchable_dropdown.dart:236:9

    ╷
236 │         FlatButton(
    │         ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/single_searchable_dropdown.dart

INFO: The import of 'package:flutter/rendering.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/single_searchable_dropdown.dart:4:8

  ╷
4 │ import 'package:flutter/rendering.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/single_searchable_dropdown.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
60
pub points
22%
popularity

Publisher

unverified uploader

Single Searchable Dropdown

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on single_searchable_dropdown