simple_time_range_picker 0.0.5 icon indicating copy to clipboard operation
simple_time_range_picker: ^0.0.5 copied to clipboard

A simple time range picker for flutter

10
likes
100/ 140
pub points
89%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 14 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/widget/time_single_picker.dart:811:47

    ╷
811 │   }) : super(repaint: PaintingBinding.instance!.systemFonts);
    │                                               ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widget/time_single_picker.dart

lib/src/widget/time_range_picker.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.