simple_sqflite 0.0.1 icon indicating copy to clipboard operation
simple_sqflite: ^0.0.1 copied to clipboard

对插件sqflite进行主要简化封装,您只需要输入sql语句即可

0
likes
115/ 140
pub points
0%
popularity

We analyzed this package 32 hours ago, and awarded it 115 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 12 API elements (75.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:simple_sqflite/simple_sqflite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:simple_sqflite/simple_sqflite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:simple_sqflite/simple_sqflite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The variable name 'DBPath' isn't a lowerCamelCase identifier.

lib/simple_sqflite.dart:8:17

  ╷
8 │   static String DBPath = "simplesqflite.db";
  │                 ^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/simple_sqflite.dart

INFO: The variable name 'RunSQL' isn't a lowerCamelCase identifier.

lib/simple_sqflite.dart:18:18

   ╷
18 │   Future<String> RunSQL(String sql) async {
   │                  ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/simple_sqflite.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path^1.8.01.8.31.8.3
sqflite^2.0.0+32.2.4+12.2.4+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
sky_engine-0.0.990.0.99
sqflite_common-2.4.2+22.4.2+2
synchronized-3.0.13.0.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

0
likes
115
pub points
0%
popularity

Publisher

unverified uploader

对插件sqflite进行主要简化封装,您只需要输入sql语句即可

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

flutter, path, sqflite

More

Packages that depend on simple_sqflite