simple_dark_mode_webview 0.1.5
simple_dark_mode_webview: ^0.1.5 copied to clipboard

A simple implementation of dark mode or dark theme webview, just for raw HTML text only.

3
likes
90/ 130
pub points
35%
popularity

We analyzed this package 40 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 24 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:simple_dark_mode_webview/simpledarkmodewebview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
webview_flutter^2.0.22.3.12.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
webview_flutter_android-2.4.02.4.0
webview_flutter_platform_interface-1.8.01.8.0
webview_flutter_wkwebview-2.5.02.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

3
likes
90
pub points
35%
popularity

A simple implementation of dark mode or dark theme webview, just for raw HTML text only.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, webview_flutter

More

Packages that depend on simple_dark_mode_webview