simple_bar_graph 0.1.1

  • Readme
  • Changelog
  • Installing
  • new59

simple_bar_graph #

Minimal graph for faily large dataset.

To install, add this to your dependencies

simple_bar_graph: ^0.1.0

Please enable SSH credentials for gitlab for this to work.

Usage #

import 'package:simple_bar_graph/simple_bar_graph.dart';

...

@override
Widget build(BuildContext context) {
    final graphController = GraphController();
    graphController.addListener(() {
        final _selected = graphController.selected;

        print(_selected);
    })

    return SimpleBarGraph(
        controller: graphController,
    );
}

Example here: https://gitlab.com/bascule-credit/simple_bar_graph/snippets/1936308

TODOs #

Allow customization to bars width

Allow toggle of group label visibility

Free utitlity to group data by dates

Documentation and clean up

0.1.1 - 30th March 2020 #

Enabled flexible initialization

0.1.0 - 10th February 2020 #

Initial publishing

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_bar_graph: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_bar_graph/simple_bar_graph.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/blackmann/simple_bar_graph was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and simple_bar_graph.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_widgets ^0.1.10 0.1.12
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
csslib 0.16.1
html 0.14.0+3
matcher 0.12.6
meta 1.1.8
path 1.6.4
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test