simple_autocomplete_search 1.0.5
simple_autocomplete_search: ^1.0.5 copied to clipboard

Simple autocomplete field with suggestions. You can customize the onPressed function and filtering function.

5
likes
90 / 130
pub points
60 %
popularity

We analyzed this package on May 12, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 13 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: SimpleAutocompleteSearch.suggestions

lib/simple_autocomplete_search.dart:12:7

   ╷
12 │ class SimpleAutocompleteSearch extends StatefulWidget {
   │       ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/simple_autocomplete_search.dart

lib/simple_autocomplete_search.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

5
likes
90
pub points
60%
popularity

Publisher

spotforest.com

Simple autocomplete field with suggestions. You can customize the onPressed function and filtering function.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on simple_autocomplete_search