simple_autocomplete_formfield 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 40

SimpleAutocompleteFormField #

A Flutter widget that wraps a TextFormField and assists with autocomplete functionality.

[0.0.2] - June 13, 2018

  • Added License (MIT).

[0.0.1] - June 13, 2018

  • First release.

example/main.dart

import 'package:flutter/material.dart';
import '../lib/simple_autocomplete_formfield.dart';

class MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: ListView(
        children: <Widget>[
          SimpleAutocompleteFormField<String>(
            itemBuilder: (context, item) => Text(item),
            onSearch: (String search) async => [
                  'a $search',
                  'b $search',
                  'c $search',
                  'd $search',
                  'e $search',
                ],
          ),
        ],
      ),
    );
  }
}

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Simple AutoComplete FormField example',
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  MyHomePageState createState() {
    return new MyHomePageState();
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_autocomplete_formfield: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_autocomplete_formfield/simple_autocomplete_formfield.dart';
  
Version Uploaded Documentation Archive
0.2.3 Sep 3, 2018 Go to the documentation of simple_autocomplete_formfield 0.2.3 Download simple_autocomplete_formfield 0.2.3 archive
0.2.2 Sep 3, 2018 Go to the documentation of simple_autocomplete_formfield 0.2.2 Download simple_autocomplete_formfield 0.2.2 archive
0.2.1 Sep 3, 2018 Go to the documentation of simple_autocomplete_formfield 0.2.1 Download simple_autocomplete_formfield 0.2.1 archive
0.2.0 Sep 3, 2018 Go to the documentation of simple_autocomplete_formfield 0.2.0 Download simple_autocomplete_formfield 0.2.0 archive
0.1.2 Aug 14, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.2 Download simple_autocomplete_formfield 0.1.2 archive
0.1.1 Jul 21, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.1 Download simple_autocomplete_formfield 0.1.1 archive
0.1.0 Jul 21, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.0 Download simple_autocomplete_formfield 0.1.0 archive
0.0.2 Jun 13, 2018 Go to the documentation of simple_autocomplete_formfield 0.0.2 Download simple_autocomplete_formfield 0.0.2 archive
0.0.1 Jun 13, 2018 Go to the documentation of simple_autocomplete_formfield 0.0.1 Download simple_autocomplete_formfield 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
80
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0