simple_autocomplete_formfield 0.2.4

SimpleAutocompleteFormField #

A Flutter widget that wraps a TextFormField and assists with autocomplete functionality.

example/lib/main.dart

demo.gif

[0.2.4] - August 6, 2019

  • Fix #6

[0.2.3] - September 3, 2018

  • Add .gif of example to README.

[0.2.0] - September 3, 2018

  • Breaking: removed itemParser and added its itemToString and itemFromString as direct parameters.
  • Breaking: containerBuilder has been renamed to suggestionsBuilder.
  • suggestionsHeight has been added since users often want to set it without having to specify the entire suggestionsBuilder.
  • Improved examples.

[0.1.2] - August 14, 2018

  • Fix missing generic type specifier in itemParser usage.

[0.1.1] - July 21, 2018

  • Fix and improve documentation.

[0.1.0] - July 21, 2018

  • Support Dart 2.0.

[0.0.2] - June 13, 2018

  • Added License (MIT).

[0.0.1] - June 13, 2018

  • First release.

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_autocomplete_formfield: ^0.2.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_autocomplete_formfield/simple_autocomplete_formfield.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Aug 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/simple_autocomplete_formfield.dart. (-1 points)

Analysis of lib/simple_autocomplete_formfield.dart reported 2 hints:

line 129 col 22: This function has a return type of 'Widget', but doesn't end with a return statement.

line 220 col 20: This function has a return type of 'String', but doesn't end with a return statement.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test