showcase 0.6.0
showcase: ^0.6.0 copied to clipboard

Generate documentation screenshots of your widgets by just annotating them.

2
likes
90 / 130
pub points
38 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 21 API elements (66.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:showcase/showcase.dart that imports:
  • package:showcase/fetch_font.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
The current Dart SDK version is 2.13.4.

Because every version of flutter_test from sdk depends on test_api 0.3.0 which depends on boolean_selector ^2.1.0, every version of flutter_test from sdk requires boolean_selector ^2.1.0.
And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.16.1 <1.16.6 depends on analyzer >=0.39.5 <2.0.0, if flutter_test any from sdk and test >=1.3.0 <1.12.0-∞ or >=1.16.1 <1.16.6-∞ then analyzer >=0.39.5 <2.0.0.
And because test >=1.15.6 <1.16.0-nullsafety depends on analyzer >=0.36.0 <0.42.0 and test >=1.15.4 <1.15.6 depends on analyzer >=0.36.0 <0.41.0, if flutter_test any from sdk and test >=1.3.0 <1.12.0-∞ or >=1.15.4 <1.16.0-nullsafety or >=1.16.1 <1.16.6-∞ then analyzer >=0.36.0 <2.0.0.
And because test >=1.9.3 <1.15.4 depends on analyzer >=0.36.0 <0.40.0 and test >=0.12.0-beta.3 <1.3.0 requires SDK version >=1.8.0 <2.0.0-∞, if flutter_test any from sdk and test >=0.12.0-beta.3 <1.16.0-nullsafety or >=1.16.1 <1.16.6-∞ then analyzer >=0.36.0 <2.0.0.
And because test >=1.16.0-nullsafety.10 <1.16.1 depends on analyzer >=0.36.0 <0.42.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.10 depends on analyzer >=0.36.0 <0.41.0, if flutter_test any from sdk and test >=0.12.0-beta.3 <1.16.0-nullsafety or >=1.16.0-nullsafety.8 <1.16.6-∞ then analyzer >=0.36.0 <2.0.0.
And because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.6 depends on yaml ^3.0.0, if flutter_test any from sdk and test >=0.12.0-beta.3 then analyzer >=0.36.0 <2.0.0 or yaml ^3.0.0.
And because showcase depends on both flutter_test any from sdk and analyzer ^0.35.0, test >=0.12.0-beta.3 requires yaml ^3.0.0.
So, because showcase depends on both yaml ^2.1.15 and test ^1.0.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

2
likes
90
pub points
38%
popularity

Publisher

borges.dev

Generate documentation screenshots of your widgets by just annotating them.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, dart_style, flutter, flutter_test, glob, http, source_gen, yaml

More

Packages that depend on showcase