short_video 0.0.1
short_video: ^0.0.1 copied to clipboard

Video palyer which can be reused by reset datasource

0
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 254 out of 968 API elements (26.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:short_video/debug/debug_s_common_action.dart that imports:
  • package:short_video/model_main.dart that imports:
  • package:short_video/util/toast.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

lib/base/i_store_db.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/base/i_store_sp.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.40.4.9+53.0.6
dio^2.1.102.2.24.0.0
flutterflutter0.0.00.0.0
fluttertoast^3.1.33.1.38.0.7
intl^0.16.00.16.10.17.0
like_button^0.1.90.1.92.0.2
logging^0.11.3+20.11.41.0.1
scoped_model^1.0.11.1.01.1.0
shared_preferences^0.5.3+40.5.12+42.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
cookie_jar-1.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.1
process-4.2.14.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.2.52.2.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.4.4` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^2.1.10` on dio does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.