shimmer_animation 0.0.8

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

shimmer_animation #

pub package

This is a new shimmer animation widget that can help you bring simple yet beautiful animations to your project with ease.

How to use #

Add shimmer_animation to pubspec.yaml of your project:

dependencies:
  shimmer_animation: ^0.0.8

Import it in your Dart code:

import 'package:shimmer_animation/shimmer_animation.dart';

Wrap any widget with Shimmer() widget to apply animaton:

  Shimmer(
    duration: Duration(seconds: 3), //Default value
    color: Colors.white, //Default value
    enabled: true, //Default value
    direction: ShimmerDirection.fromLTRB(),  //Default Value
    child: Container(
      color: Colors.deepPurple,
    ),
  ),

A preview of this:

Shimmer Animation

License #

MIT License.

[0.0.8] - What's new! #

  • Remove debug prints which were annoying for developers!

[0.0.7] - 2020-06-18 #

  • Fix issues with flutter web

[0.0.6] - 2020-06-01 #

  • Added possibility to change animation direction
  • You can now move the animation in 8 possible directions
  • You can now have the animation move in 8 possible directions

[0.0.5] - 2020-06-01 #

  • Added possibility to change animation duration
  • (for developers) Moved all default values to one file

[0.0.4] - 2020-05-17 #

  • Update example for better understanding
  • Add usage details in readme
  • Add license details to readme

[0.0.3] - 2020-05-16 #

  • Fix example not visible on pub
  • Add gif to readme
  • improve usability

[0.0.2] - 2020-05-16 #

  • Added Example
  • Updated Readme
  • Reformat code for better understanding

[0.0.1] - 2020-05-16 #

  • First Version of shimmer animation.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:shimmer_animation/shimmer_animation.dart';

void main() {
  runApp(FullPageShimmerExample());
}

class FullPageShimmerExample extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: ShimmerPage(),
    );
  }
}

class ShimmerPage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Shimmer(
        duration: Duration(seconds: 3), //Default value
        color: Colors.white, //Default value
        enabled: true, //Default value
        direction: ShimmerDirection.fromLTRB(), //Default Value
        child: Container(
          color: Colors.deepPurple,
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shimmer_animation: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shimmer_animation/shimmer_animation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • shimmer_animation that is a package requiring null.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test