shell_command_flutter 1.0.0
shell_command_flutter: ^1.0.0 copied to clipboard

Execute the Native commands with respect to platform like Windows,MacOS,Linux

1
likes
50 / 110
pub points
8 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/theshivamlko/shell_command_flutter.git was unreachable.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/theshivamlko/shell_command_flutter/issues was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 12 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:shell_command_flutter/shell_command_flutter.dart that declares support for platforms: Android, Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/shell_command_flutter.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/ResultSet.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
50
pub points
8%
popularity

Execute the Native commands with respect to platform like Windows,MacOS,Linux

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

shivam@navoki.com

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on shell_command_flutter