shared_preferences_settings 1.2.0

Flutter Android iOS web

Settings Screen with Shared Preferences

16
likes
60 / 110
pub points
86 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 28 out of 217 API elements (12.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:shared_preferences_settings/shared_preferences_settings.dart that imports:
  • package:shared_preferences_settings/src/settings_screen.dart that imports:
  • package:shared_preferences_settings/src/settings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:shared_preferences_settings/shared_preferences_settings.dart that imports:
  • package:shared_preferences_settings/src/settings_screen.dart that imports:
  • package:shared_preferences_settings/src/settings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform iOS

Because:

  • package:shared_preferences_settings/shared_preferences_settings.dart that imports:
  • package:shared_preferences_settings/src/settings_screen.dart that imports:
  • package:shared_preferences_settings/src/settings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform macOS

Because:

  • package:shared_preferences_settings/shared_preferences_settings.dart that imports:
  • package:shared_preferences_settings/src/settings_screen.dart that imports:
  • package:shared_preferences_settings/src/settings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform Web

Because:

  • package:shared_preferences_settings/shared_preferences_settings.dart that imports:
  • package:shared_preferences_settings/src/settings_screen.dart that imports:
  • package:shared_preferences_settings/src/settings.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

lib/src/settings_screen.dart:355:7

    ╷
355 │       Future.delayed(Duration.zero, () {
    │       ^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/settings_screen.dart

INFO: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

lib/src/settings_screen.dart:360:7

    ╷
360 │       Future.delayed(Duration.zero, () {
    │       ^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/settings_screen.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_colorpicker^0.3.20.3.40.3.4
rxdart^0.23.10.23.10.24.1
shared_preferences^0.5.6+30.5.100.5.10
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.16.1
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:18:11

   ╷
18 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs