shared_config 1.0.3 icon indicating copy to clipboard operation
shared_config: ^1.0.3 copied to clipboard

Package to shared config for entire app(env, lints, scripts)

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 36 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

SDK issues found:

Package is not compatible with the Dart SDK.

Because:

  • shared_config that depends on:
  • flutter_dotenv that is a package requiring flutter.
* ✓ Android * ✓ iOS * ✓ Windows * ✓ Linux * ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:shared_config/share_config.dart that imports:
  • package:flutter_dotenv/flutter_dotenv.dart that imports:
  • package:flutter_dotenv/src/dotenv.dart that imports:
  • package:flutter/widgets.dart that imports:
  • dart:ui
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

ERROR: Don't access members with this unless avoiding shadowing.

lib/share_config.dart:10:5

   ╷
10 │     this.baseApiUrl = DotEnv().env['BASE_API_URL'];
   │     ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/share_config.dart

ERROR: Don't access members with this unless avoiding shadowing.

lib/share_config.dart:11:5

   ╷
11 │     this.env = DotEnv().env['ENV'];
   │     ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/share_config.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutter_dotenv^2.1.02.1.05.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
flutter-0.0.00.0.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^2.1.0 on flutter_dotenv does not support the stable version 3.0.0.

Try running dart pub upgrade --major-versions flutter_dotenv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

Package to shared config for entire app(env, lints, scripts)

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter_dotenv

More

Packages that depend on shared_config