shared_aws_api 0.1.5 icon indicating copy to clipboard operation
shared_aws_api: ^0.1.5 copied to clipboard

Shared protocol implementation and utilities for generated AWS API clients.

0
likes
70/ 130
pub points
74%
popularity

We analyzed this package 10 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 86 API elements (8.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/protocol/_sign.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.53.0.1
http^0.12.0+20.12.20.13.4
intl^0.16.10.16.10.17.0
json_annotation^3.0.03.1.14.4.0
meta^1.1.81.7.01.7.0
xml^3.7.03.7.05.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
http_parser-3.1.44.0.0
path-1.8.11.8.1
petitparser-3.1.04.4.0
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Dart 2.15.1.

0
likes
70
pub points
74%
popularity

Publisher

shield icon for verified publishersaws-dart.agilord.com

Shared protocol implementation and utilities for generated AWS API clients.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

crypto, http, intl, json_annotation, meta, xml

More

Packages that depend on shared_aws_api