share 2.0.1
share: ^2.0.1 copied to clipboard

Flutter plugin for sharing content via the platform share UI, using the ACTION_SEND intent on Android and UIActivityViewController on iOS.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add share

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  share: ^2.0.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:share/share.dart';
1282
likes
100
pub points
99%
popularity

Publisher

flutter.dev

Flutter plugin for sharing content via the platform share UI, using the ACTION_SEND intent on Android and UIActivityViewController on iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, meta, mime

More

Packages that depend on share