seti 0.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

seti-flutter #

pub

Seti file icons for Flutter. Show file icon for different file types, auto detected by file name.

Usage #

import 'package:flutter/widgets.dart';
import 'package:seti/seti.dart';

class MyWidget extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return SetiIcon(
      // File name
      'main.dart',

      // Icon size
      size: 32,
    );
  }
}

License #

MIT

[0.2.0] - 2019-09-11

  • Refactor

[0.1.0] - 2019-09-09

  • First release

example/main.dart

import 'package:flutter/widgets.dart';
import 'package:seti/seti.dart';

class MyWidget extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return SetiIcon(
      // File name
      'main.dart',

      // Icon size
      size: 32,
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  seti: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:seti/seti.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/data.dart. (-9.54 points)

Analysis of lib/data.dart reported 20 hints, including:

line 5 col 7: The declaration '_apple' isn't referenced.

line 16 col 7: The declaration '_checkbox_unchecked' isn't referenced.

line 17 col 7: The declaration '_checkbox' isn't referenced.

line 18 col 7: The declaration '_cjsx' isn't referenced.

line 23 col 7: The declaration '_coffee_erb' isn't referenced.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
dart_style ^1.2.10
flutter_test
http ^0.12.0